Решение 19 задания ОГЭ 2017 по информатике из демоверсии

Решение 19 задания ОГЭ 2017 по информатике из демоверсии. Это задание второй части с развернутым ответом, высокого уровня сложности. Примерное время выполнения задания 30 минут. За это задание можно максимально набрать 2 балла. Задание выполняется на компьютере.

Проверяемые элементы содержания:
– умение проводить обработку большого массива данных с использованием средств электронной таблицы или базы данных.

Описание элементов содержания, проверяемых в ходе экзамена:
– базы данных,
– поиск данных в готовой базе,
– создание записей в базе данных,
– таблица как средство моделирования,
– ввод данных в готовую таблицу,
– изменение данных,
– переход к графическому представлению,
– ввод математических формул и вычисления по ним,
– представление формульной зависимости в графическом виде.

19 задание ОГЭ 2017 по информатике

В электронную таблицу занесли данные о калорийности продуктов. Ниже приведены первые пять строк таблицы.

Решение 19 задания ОГЭ 2017 по информатике

В столбце A записан продукт; в столбце B – содержание в нём жиров; в столбце C – содержание белков; в столбце D – содержание углеводов и в столбце Е – калорийность этого продукта.
Всего в электронную таблицу были занесены данные по 1000 продуктам.
Выполните задание
Откройте файл с данной электронной таблицей (расположение файла Вам сообщат организаторы экзамена).

Скачать для Microsoft Excel (57 КБ, xlsx): файл с электронной таблицей для 19 задания
Скачать для OpenOffice.org Calc (42 КБ, csv): файл с электронной таблицей для 19 задания

На основании данных, содержащихся в этой таблице, ответьте на два вопроса.
        1. Сколько продуктов в таблице содержат меньше 50 г углеводов и меньше 50 г белков? Запишите число, обозначающее количество этих продуктов, в ячейку H2 таблицы.
        2. Какова средняя калорийность продуктов с содержанием жиров менее 1 г? Запишите значение в ячейку H3 таблицы с точностью не менее двух знаков после запятой.
Полученную таблицу необходимо сохранить под именем, указанным организаторами экзамена.

Решение 19 задания ОГЭ 2017 по информатике

Решение для OpenOffice.org Calc и для Microsoft Excel

Первая формула используется для русскоязычной записи функций; вторая – для англоязычной.

1) В ячейку F2 запишем формулу

=ЕСЛИ(И(D2<50;C2<50);1;0)
=IF(AND(D2<50;C2<50);1;0)

2) Скопируем формулу во все ячейки диапазона F3:F1001.

3) В ячейку H2 запишем формулу

=СУММ(F2:F1001)
=SUM(F2:F1001)

4) В ячейку H3 запишем формулу

=СУММЕСЛИ(B2:B1001; ″<1″;E2:E1001)/СЧЁТЕСЛИ(B2:B1001;″<1″)
=SUMIF(B2:B1001; ″<1″;E2:E1001)/COUNTIF(B2:B1001;″<1″)

Можно решить и другими способами.

Если задание выполнено правильно, то должны получиться следующие ответы:

на первый вопрос: 864;
на второй вопрос: 89,45.

2 балла за задание дается если
Получены правильные ответы на оба вопроса. Допустима запись ответа в другие ячейки (отличные от тех, которые указаны в задании) при условии правильности полученных ответов. Допустима запись ответов с большей точностью.

1 балл за задание дается если
Получен правильный ответ только на один из двух вопросов.

0 баллов за задание дается если
Правильные ответы не получены ни на один из вопросов.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *