Решение 20.1 задания ОГЭ 2017 по информатике из демоверсии

Решение 20.1 задания ОГЭ 2017 по информатике из демоверсии. Это задание второй части с развернутым ответом, высокого уровня сложности. Примерное время выполнения задания 45 минут. За это задание можно максимально набрать 2 балла. Задание выполняется на компьютере.

Проверяемые элементы содержания:
— умение написать короткий алгоритм в среде формального исполнителя.

Описание элементов содержания, проверяемых в ходе экзамена:
— алгоритм,
— свойства алгоритмов,
— способы записи алгоритмов,
— блок-схемы,
— представление о программировании,
— алгоритмические конструкции,
— логические значения,
— операции,
— выражения,
— разбиение задачи на подзадачи,
— вспомогательный алгоритм,
— обрабатываемые объекты (цепочки символов, числа, списки, деревья).

20.1 задание ОГЭ 2017 по информатике

Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может.
У Робота есть девять команд. Четыре команды – это команды-приказы:
вверх
вниз
влево
вправо
При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑, вниз ↓, влево ←, вправо →. Если Робот получит команду передвижения сквозь стену, то он разрушится.
Также у Робота есть команда закрасить, при которой закрашивается клетка, в которой Робот находится в настоящий момент.
Ещё четыре команды – это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений:
верху свободно
снизу свободно
слева свободно
справа свободно
Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид:
если условие то
последовательность команд
все
Здесь условие – одна из команд проверки условия.
Последовательность команд – это одна или несколько любых команд-приказов.
Например, для передвижения на одну клетку вправо, если справа нет стенки, и закрашивания клетки можно использовать такой алгоритм:
если справа свободно то
вправо
закрасить
все
В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:
если (справа свободно) и (не снизу свободно) то
вправо
все
Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:
нц пока условие
последовательность команд
кц
Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:
нц пока справа свободно
вправо
кц

Выполните задание.
На бесконечном поле есть горизонтальная и вертикальная стены. Левый конец горизонтальной стены соединён с нижним концом вертикальной стены. Длины стен неизвестны. В вертикальной стене есть ровно один проход, точное место прохода и его ширина неизвестны. Робот находится в клетке, расположенной непосредственно над горизонтальной стеной у её правого конца.
На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).

20.1 ОГЭ 2017 1

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные непосредственно левее и правее вертикальной стены. Проход должен остаться незакрашенным. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).

Решение 20.1 задания ОГЭ 2017

При исполнении алгоритма Робот не должен разрушиться, выполнение алгоритма должно завершиться. Конечное расположение Робота может быть произвольным.
Алгоритм должен решать задачу для любого допустимого расположения стен и любого расположения и размера прохода внутри стены.
Алгоритм может быть выполнен в среде формального исполнителя или записан в текстовом редакторе.
Сохраните алгоритм в текстовом файле. Название файла и каталог для сохранения Вам сообщат организаторы экзамена.

Решение 20.1 задания ОГЭ 2017 по информатике

Команды исполнителя будем записывать жирным шрифтом, а комментарии – курсивом. Начало комментария будем обозначать символом «|» (во время выполнения работы записывать комментарии не обязательно).

|Двигаемся влево, пока не дойдём до вертикальной стены.
нц пока слева свободно
        влево
кц

|Двигаемся вверх, пока не дойдём до прохода в стене, и закрашиваем клетки.
нц пока не слева свободно
        закрасить
        вверх
кц

|Двигаемся дальше до вертикальной стены.
нц пока слева свободно
        вверх
кц

|Двигаемся вверх до конца стены и закрашиваем клетки.
нц пока не слева свободно
        закрасить
        вверх
кц

|Обходим стену.
        влево
        вниз

|Двигаемся вниз, пока не дойдём до прохода в стене, и закрашиваем клетки.
нц пока не справа свободно
        закрасить
        вниз
кц

|Двигаемся дальше до вертикальной стены.
нц пока справа свободно
        вниз
кц

|Двигаемся вниз до конца стены и закрашиваем клетки.
нц пока не справа свободно
        закрасить
        вниз
кц

Возможны и другие варианты решения.
Допускается использование иного синтаксиса инструкций исполнителя, более привычного для учащихся.
Допускается наличие отдельных синтаксических ошибок, не искажающих замысла автора решения.

2 балла за задание дается если
Алгоритм правильно работает при всех допустимых исходных данных.
1 балл за задание дается если
При всех допустимых исходных данных верно следующее:
1) выполнение алгоритма завершается, и при этом Робот не разбивается;
2) закрашено не более 10 лишних клеток;
3) остались незакрашенными не более 10 клеток из числа тех, которые должны были быть закрашены.
0 баллов за задание дается если
Задание выполнено неверно, т. е. не выполнены условия, позволяющие поставить 1 или 2 балла.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

9 + 12 =