От программы, записанной на алгоритмическом языке, перейдите к записи программы на языке Паскаль

От программы, записанной на алгоритмическом языке, перейдите к записи программы на языке Паскаль. Определите, что будет выведено в результате работы программы.

алг
цел s, k
нач
s:=0
нц для k от 1 до 5
s:=s+2*k
кц
вывод s
кон

Решение

Программа на языке Паскаль

program N_199
var s, k: integer;
begin
s:=0;
for k:=1 to 5 do
s:=s+2*k;
writeln (‘s = ‘, s);
end.

s k k<=5
0
2 1 да
6 2 да
12 3 да
20 4 да
30 5 да
6 нет

Ответ:
На экран будет выведено s = 30

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

четыре × три =